
LAE DL28W: Instructions 
1. INTRODUCTION 

 
DL28W is a flexible data logging system consisting of: 

 

 DL28W data logging module; 

 DL28_SW software for programming of DL28W, retrieving and displaying logged data from it. 
 

DL28W may work as a standalone module, with its own NTC10K probe, digital input and changeover 
alarm relay, which activates in case of alarm condition. 
 

Moreover, the DL28W may be used as a master to log data coming from up to 4 connected 
peripherals via the RS485 line and using ModBus ASCII protocol. 
 

DL28W must be first configured by means of the DL28_SW PC software, then it can be used in the 
field, where it will collect data. The logged values may at any time be retrieved via the connected USB drive, 
Bluetooth™ or USB cable. 
 

 
Figure 1 - DL28W components 



 

2. DESCRIPTION 
 

2.1. LED 
 

 RUN LED 
Power up : 5 flashings per second during initialization; 
Run : 1 flashing per second. Logging in progress; 
Error : 3 short flashings every 2 seconds, in case of communication error with the connected 

devices (slot#2…slot#5); 
 

 USB LED 
Normally off, this LED will blink when logged data are transferred to a connected USB drive. At 

the end of the transfer operation, the LED will stay lit. 
 

2.2. SLOT 
 

The datalogger DL28W features one NTC10K probe input, one digital input and one relay output. 
These three I/O values can be logged under the name of “Slot#1”. 

The datalogger can also log values taken from external devices called “Slot #2”, “Slot #3”, “Slot t#4” 
and “Slot #5” in the DL28_SW software. 
 

2.3. RJ-45 MODBUS CONNECTION 
 

Connector for a 2-wire cable used to link up to four external devices. The protocol used is ModBus 
ASCII, baud 9600, 7 data bits, Even parity, 1 stop bit.  

Every LAE Electronic controller fitted with RS485 is compatible with this system. 
 

2.4. USB DEVICE 
 

Connector for a USB cable to a PC running DL28_SW software. 
Used to set/read the datalogger configuration, and retrieve data stored in a datalogger. The data are 
imported directly into the DL28_SW software. 
 

2.5. USB HOST 
 

Connector for a USB pen drive. 
It’s used to retrieve data stored in the datalogger and to save them in a USB pen drive. The data in the USB 
can then be imported to a PC via the DL28_SW software. 
 

2.6. BLUETOOTH® 
 

Optional internal module that enables the communication with Android™1 Smartphone or PC via 
Bluetooth®. 
 
 
 
 

                                                      
1 Android is a trademark of Google Inc. 



 
 

2.7. EXTERNAL BATTERY 
 

This connector is suitable for an optional external battery, which will be used to continue the 
logging in case of a power failure. 
 
 

3. TECHNICAL DATA 
 

Temperature Input 
Probe 

Type NTC 10KΩ @ 25°C 

Range -50... 110°C 

Accuracy <0.5°C 

Output Alarm Relay Max. Load 5(1)A; 240Vac 

Max. No. devices   4x RS485 

Internal Mass Memory   4 MByte 

Bluetooth® Specification compliant V2.1 

Range class-2 

USB Connection Type A2.0, B2.0 

Internal buffer battery   >20 day, self-rechargeable 

External Battery Voltage 7…12V 

Consumption 75mAh 

Connector XAP-02V-1 (JST) 

Power supply   100...240 Vac, 50/60 Hz, 3W 

Operating Conditions   -10 … +50°C; 15% … 80% r.H. 

 

4. DL28SW  - SOFTWARE CONTROL PANEL 
 

4.1. REQUIREMENTS 
 
Operating System: Microsoft Windows XP/Vista/7/8 
LabVIEW 2009 SP1 Runtime (http://joule.ni.com/nidu/cds/view/p/id/1600/lang/en) 
VISA 4.6.2 Runtime (http://joule.ni.com/nidu/cds/view/p/id/1606/lang/en) 
 
 
 
 
 
 
 
 
 
 
 



 
 

4.2. DESCRIPTION 
 
The software main screen:  
 

 
 
The main functions of the software are: 
 

 DL28W setup (password protected):  

 Set date and time of DL28W (password protected):  

 Import recorded data from the DL28W :  

 See graph and Excel files of imported data:  
 
When operating with a connected DL28W, remember to select the proper COM port: 
Menu Options → COM port → select a COM port and click on “Save and Open port”. 
Click on “Test” button to verify there is communication with DL28W. 

  
The first operation to do with a new DL28W is to create a configuration and set its date and time. 
 
 
 

4.3. SET UP DL28W 

Click on the button:  to create or edit a DL28W configuration. 
 



 
 

On the right side, the group “Datalogger” represents the DL28W. 
On the left side, there is a list of saved files, called “templates”, each holding the configuration of 

an external slot (controller connected). 
The DL28W configuration will be created in the memory and can then be sent to a connected 

DL28W (pressing the green button “Send”) or saved to a script file for a USB pen drive (pressing “Save to 
script”), in the event that the DL28W is not connected to a PC, or saved to a PC hard disk for future 
reference (pressing “Save”). 
 

4.3.1. CREATE A NEW TEMPLATE FOR AN EXTERNAL DEVICE 
 

The DL28SW comes with two pre-made templates for two LAE Electronic controller models called 
“BD1-28” and “BIT-25”. 

To create a new template: press Control+N, or choose Slot  New. 
To edit a template: select the template to edit, press Control+E or double click on a template. 

 
In the “Slot” group, fill the information about the 
device, its ModBus address and the logging period in 
seconds. 
 
In the “Device” group fill up to eight registers. 
On the first left column enter the register address. 
LAE Electronic provides a list of addresses for each 
controller; for example, by default, register 0 is the 
AIR probe, register 1 is the EVAPORATOR probe and 
register 2 is the AUX probe, if fitted. 
The unit column indicates if the register value must 
be treated as a decimal or an integer. The most 
recent LAE electronic controllers (BIT25, BD1-28, 
BR1-28) provide their values only as integers x10 in 
Celsius degrees, so it's necessary to choose "0.1°C" 
in order for the temperature value to be divided by 



10, obtaining a decimal point resolution. 
Example 1: 
BIT25 air probe measures “9.8 °C” -> DL28W will retrieve the value “98”, but with Unit=0.1°C in the 
configuration the software will store “9.8” °C both in the Excel and archive file. 
Example 2: 
BD1-28 evaporator probe measures “45 °F” -> DL28W will retrieve the value “72”, but with Unit=0.1°C in 
the configuration the software will store “7.2” °C both in the Excel and archive file. 
 
For all the other recent or less recent controllers, you may either choose “0.1°C” decimal point or “1°C” 
resolution, depending on what has been selected as display resolution in the SCL controller parameter. 
Example 3:  
AT2-5 with SCL = 2°C2, the air probe measures “9 °C” -> DL28W will retrieve the value “9”; with Unit=1°C in 
the configuration the software will store “9” °C both in Excel and archive file. 
If SCL = 1°C on AT2-5, the controller will be able to measure with decimal precision, for example “9.3 °C”, 
the DL28W will retrieve “93” and the configuration must have Unit=0.1°C. 
 
“Unit = DIGITAL” has to be chosen for states only, such as Defrost, Alarm, etc...  
“Description” is a field used to explain the meaning of the address and it will appear in the graph legend 
and as a column header on Excel files. 
 
NOTE: each template may have its own different logging rate. The DL28W will independently retrieve the 
selected address values from each device connected at the selected rate. 
 
Once done, click on Save to save the template to disk. 
 

4.3.2. ADD/REMOVE AN EXTERNAL DEVICE TO/FROM DL28W CONFIGURATION 
 

Select a template from the list of templates, and click on “Add”. 
This will add the template to the first free external slot available of the DL28W configuration, and 

it will appear in the “external devices” list. 
Column “Adr” indicates the ModBus address of the external slot, taken from the template, and the 

“Estimated logging period” will show an estimated maximum period of time after which the oldest logs will 
be lost3. 

 To edit the in-memory configuration of an external slot, double click on its row, edit and click on 
“Save”. If the logging period has been changed, the estimated period will change accordingly. 

To remove a slot from the configuration, select it from the list in the “external devices” on the right 
(in the “datalogger group”), and click on “Remove”. 

To remove a slot from the configuration AND save it to disk, click on “Remove & Import” 
 
 
 
 
 
 

4.3.3. ADD/REMOVE AN INTERNAL DEVICE TO/FROM DL28W CONFIGURATION 
 
The internal device is named “Slot #1” and consists of an NTC10K probe input and a digital input. 
Double click on “Estimated logging period” in the “internal device” to open the configuration for the 

                                                      
2 SCL values for AT2-5 are: 1°C (Celsius with 1 decimal point), 2°C (Celsius without decimal point), °F (Fahrenheit without decimal 
point). With 2°C the possible values are only integers (9,10, 11, etc…) 
3 DL28W has a 4Mbytes internal circular memory. When it is full, the oldest records will be overwritten. 



internal device: 
  
In the “Logging” group, select the variable 
to be logged, i.e. probe temperature 
and/or the digital input state. In addition 
set an appropriate logging period 
(expressed in seconds); then click on 
“Save” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

4.3.4. MANAGE A CONFIGURATION 
 

Once the whole DL28W configuration has been prepared: 
 
 Press “Save” to save it to disk; 
 Press “Load” to retrieve a previously stored configuration from disk; 
 Press “Send” to send the configuration to a connected DL28W via COM port; 
 Press “Save to script” to save it as a script file in a USB pen drive, for offline usage; 
 Press “Receive” to read and display the configuration of a connected DL28W via COM port. 

 
ID: it is the identification number of DL28W. When several DL28W’s are used, this ID differentiates 

them, so that the imported data will be associated to the corresponding DL28W. 
 

 
 

4.4. SET DL28W DATE AND TIME 
 



 

The DL28W has a built-in RTC (Real Time Clock) that must be set correctly, otherwise all the values 
recorded will feature a meaningless date and time field and it will be impossible to draw a graph or extract 
an excel file. 
 
 
Click on the button: 
 
 
 
 
 
 
 
Select the date and time or enter the value. 
 
The new date and time can be sent to the DL28W in two ways: 
 
Via USB pen drive:  
Click on "Set via script". This button will generate a file, called "script" which includes the commands to set 
date and time of a DL28W. This script must be placed in the root folder of a USB pen drive. 
WARNING: this operation will also delete all the previously collected records of the DL28W, in order to avoid 
time discrepancies. 
 
Via USB cable / Bluetooth®: 
Click on “Set via COM port”. This button will start a communication with DL28W using the selected COM 
port,  and the software will issues the commands via cable or wireless. 
WARNING: this operation will also delete all the previously collected records of the DL28W, in order to avoid 
time discrepancies. 
 
 

4.5. IMPORT RECORDED DATA FROM DL28W TO PC 
 

The stored records from a DL28W may be downloaded to the PC in several ways: 
 
 Through a USB pen drive; 
 Through a USB cable connected to PC; 
 Through an Android® Smartphone or PC by Bluetooth®. 

 
Once data have been imported to PC, they are stored in an archive file under \Logs subfolder. 
 

4.5.1. IMPORT VIA USB PEN DRIVE 
 

With this method, recorded logs are first transferred from a DL28W to a USB pen drive, they can then 
be imported into the PC. 

The USB pen drive must contain a particular “script file” in its root folder. 
A “script file” is a text file which contains instructions for the DL28W; it can be created automatically 

by the software: select “Commands” → “Generate read log script” 
 



       
 
In the following dialogue box, select the number of days of data to retrieve.  
Click on “continue” and select the USB root folder (example: “D:\” ). 
Later, the USB pen drive will be connected to the DL28W USB Host port and the green LED will start 
blinking, meaning transfer in progress, until the LED stops blinking and the USB pen drive can be removed 
safely. 
Take the USB pen drive and connect it to the PC. 
Open datalogger control panel. 

Click on the retrieve data button:  
 
 
 
 
 
 
 
 
 
 
 
 

Maximum number of records: Specify the maximum number of rows for each 
Excel file that will be generated after a successful import. 
 
Click on “From FOLDER” 
Navigate to the USB drive folder and select it. 
If successful, you will see a summary report. 
The summary report indicates: 
 

 The datalogger ID 

 The global statistics: total number of records, the oldest and most recent date. 

 The slot statistics: for each slot in the DL28W configuration, the number of stored records, the 
oldest and the most recent date 

 

4.5.2. IMPORT VIA CONNECTED USB CABLE 
 

 Connect a USB cable from PC to DL28W, and a Virtual COM port will be created. 
To know the COM port number, go to the PC System Properties on the Windows Control Panel. 

 Launch the datalogger control panel software. 

 From menu select Options → COM port. Select the correct COM port and click on Test. 

 If a message from the datalogger appears, the communication is established 
 



 
 Click on “Save and Open Port” 

 Click on “Retrieve logged data”  

 Click on “From COM port” 

 The communication will start and the summary report will appear eventually. 
 

4.5.3. IMPORT VIA BLUETOOTH® 
 

The DL28W-D version has a Bluetooth® module. A compatible Bluetooth® system must be used at 
the PC side and the Bluetooth® Vendor will have to provide a Virtual COM port driver. 
Then proceed as per 4.5.2. 
 

4.5.4. IMPORT VIA SMARTPHONE 
 

An Android™ smartphone or tablet may be used to communicate with the DL28W via Bluetooth®, 
by means of an app called “LAE Datalogger” (https://play.google.com/store/apps/details?id=com.lae.Logger). 

The data downloaded are not stored in the smartphone/tablet but may be forwarded to a recipient 
via an e-mail attachment. 

On the receiver’s side, save the email attachments to a folder, then proceed as per 4.5.1 
 

4.6. GRAPHS AND EXCEL 
 

Click on button:  to open the graphs. 
In “Archives” there will be a list of datalogger archive files.  
Their name is formed by the datalogger ID, underscore, the date of the first log and the date of the last log 
(in the format yyyy-mm-dd). 
When a new data import has been completed, this file will be updated with the newly recorded values. 
There can be only one archive per configuration: every time data are imported from a given data logger ID, 
the software will detect if the configuration matches the one of the archive. If it does, the new data may be 
added safely, alternatively the software will ask to move the archive file to another folder and will create a 
new archive. 
 
Double click on the archive name, the archive content will appear. If a slot has not been configured, there 
will appear “Slot Disabled”, alternatively the slot description will appear. 
Slot #1 description will be fixed : “Datalogger Internal Device” 
 
Double click on a slot to display the graph of the registers logged (up to 8 lines), and graph legend will be 
updated. 
Use navigation graph controls to zoom in/out or pane/move the graph area. 
Tick the symbol next to the plot legend to hide that chart. 
 

https://play.google.com/store/apps/details?id=com.lae.Logger


 
Figure 2- Graph example 1 

 

 
Figure 3- Graph example 2 

The software generates Excel compatible files after each import. 
Choose File -> Open Excel folder to open the folder of Excel files. 



 
Figure 4- Excel example 1 

 

 
Figure 5 - Excel example 2 

 
 

4.7. OTHER ADVANCED OPTIONS 
 

4.7.1. DL28W RELAY CONFIGURATION 
 

The DL28W features an SPDT (Single Pole Double Thru) relay called “Alarm relay”. 
It can be configured in the advanced settings of the slot #1. 

Click on button : then double click on Slot#1 “estimated logging period”; the "Alarm relay" 
group sets the conditions for the alarm relay to activate. 

These conditions are gathered as “internal” and “external”, where the “internal” ones are those that 
originate in the DL28W hardware and the "external" ones are those originating in the connected devices. 
 

The internal alarm sources are: 



digital input, communication error with the external devices, the 
integrated probe failure detection, or a detection of a power 
failure. 
 
The external alarm sources are enabled only if at least one 
connected device was previously added to the configuration, 
and they are chosen among the logged registers. 
 
Each external slot register is a 16 bit integer value. It is possible 
to choose one particular bit (0 to 15) or any bit, so that the 
alarm relay will make when the bit value is 1. 
 
Each external source is a logged register. Click on “Config slot #”, 
and select the external slot that will be the source of alarm, then 
select one of the logged registers for that slot, and finally the bit 

of that register that will get the alarm relay to make. 
 
 

5. COPYRIGHTS AND TRADEMARKS 
 
Bluetooth is a registered trademark of Bluetooth SIG Inc. 
Microsoft, Windows, Excel are registered trademarks of Microsoft Corporation. 
Android is a trademark of Google Inc. 
 


